I need help guys PCI simple communications controler
1 1

16 posts in this topic

Recommended Posts

Those of you that know me, no I am A Technophobe

My PC was running slow, so I started to delete stuff that I didn't think i needed or used DER

 

Now when I switch on my PC (windows XP)

The screen says I have problem with new hardware found like  my printer installing it comes up with

PCI simple communications controler, and tries for ages but nothing happens, although the printer works OK

same thing happens when I connect my Windows phone Nikia 630

I cancel the new hardware found icons and they work

 

I have tried to download it again, but end up with a scan of all drivers that need updating. then they want to charge me

 

Any ideas what I can do

Share this post


Link to post
Share on other sites

The charge thing sounds like you have installed some kind of helper app to scan drivers for you.

For the printer, go to the manufacturers website and download the installer file.

Share this post


Link to post
Share on other sites

cheers mark that exactly what I down loaded

I will go to the Epson site and try that although I have tried the disc that cam e with it and it comes up with the same PCI controller thing

Share this post


Link to post
Share on other sites

I have been on the site and down loaded some new drivers

But

When I re start computer same thing happens

i get a box on my screen

 

Found new hardware wizard

A big yellow question mark and the worrds "PCI simple communications controler," and a maginfying glass hovering over a screen

it goes on for ever. It lets me click back or cancel

i have tried putting the printer disc in at same time

Eventualy when I click back it starts again and when i click cancel it says the hardware may not work correctly

but it seems to

and same thing with my windoows phone

Share this post


Link to post
Share on other sites

Best thing I can recommend to solve the issue of the messages, is to google, "PCI simple communications controller pop up problem", or something specific to what you'd like to solve. It's likely someone's experienced this before and posted about it.

 

If you are looking to speed up your pc and are not too computer savvy, I'd recommend either Glary Utilities or Iobit's Advanced System Care. Both are free. Both come with registry cleaners, defragment options, disk error checks, system error checks, privacy checks etc.

 

Both will help speed up your computer with a few clicks, and won't take long to figure out.

Share this post


Link to post
Share on other sites

Thank you for all the advice

 

Well i tried everything down loaded loads of stuff

learnt alot about my PC

got everything working but not myWindows 625 window  Phone

Mrs T has the same phone and hers works in the uSB port

mine still doesnt, but it charges

so may be a fault or the port ??

Share this post


Link to post
Share on other sites

Rob, is she using the same type of phone on another computer or yours? If she is using a different computer (presumably not XP), then the likelyhood is that you do not have the drivers for the phone installed on your computer. Go to the phone maker's website and see if they have an installation package for Windows XP.

 

If she is using the same type of phone on your computer using the same cable and port, then it is a problem with your phone. You can call your suppliers technical helpline, BUT they are likely to tell you that XP is no longer supported.

Share this post


Link to post
Share on other sites

Well thanks for all the advice guys

I think it is sorted

My wife had exactly the same phone, same cable same PC

Hers works mine didn’t

 

Mine wouldn’t work on any PC or cable, but it charged

 

My mate at work, stopped one of my apps running, switched off the phone, removed the STD card. Switched it back on and it worked on the PC

He switched it off again replaced the STD card and Switched it back on and it worked on the PC.

 

All is now fine. Could it have been the app was running?

I have no idea but its working and with all the down loads updated drivers uninstalled a load of stuff etc I have  my PC is a load faster too

Share this post


Link to post
Share on other sites

Sorry Rob, you had me laughing with STD card, a family member of mine used to say the exact same thing! :)

 

STD's are bad!! :D

 

Glad you sorted it, computers generally have little tantrums, I learn't alot in my teenage years from taking them apart and putting them back together.... only way to learn sometimes is trial and error or to think of the simplest thing possible!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1